Akuvox IT88P – High performance High Definition (HD – 1080P) touch screen for your home
The Akuvox IT88S multifunctional communicator, with an Android 9.0 operating system, provides audio and high definition video communication with door phones via SIP 2.0 protocol. It delivers the ultimate touch screen experience in an unobtrusive, space-saving design featuring a brilliant 10-inch capacitive touch screen display.
Akuvox 10 Inch HD SIP Indoor Monitor IT88S – Android
Guest Price – Login to see Member Pricing
Login, Register, or Call for Price
10 HD INDOOR MONITOR ANDROID VERSION
Description
Akuvox IT88P – High performance High Definition (HD – 1080P) touch screen for your home
The Akuvox IT88S multifunctional communicator, with an Android 9.0 operating system, provides audio and high definition video communication with door phones via SIP 2.0 protocol. It delivers the ultimate touch screen experience in an unobtrusive, space-saving design featuring a brilliant 10-inch capacitive touch screen display.
Akuvox IT88S At a Glance:
Physical and Power
Frontpanel: Aluminium alloy
RAM/ROM :2GB/8GB
Display: 10 Inch IPS LCD
Screen: 10 Inch capacitive touch screen
Memory slot: 1 Micro SD slot
RS485 port: Support
Relays out: 2
Bell in: 1
IO: 8 (alarm Sensors)
Microphone: -26dB
Speaker: Dual speakers, 4?/3W
Ethernet ports: 1xRJ45, 10/100Mbps adaptive
802.3af Power-over-Ethernet
12V DC connector (if not using PoE)
Tamper resistant: Support
Installation: Wall-mounted &Desktop
Dimension: 251×182.5×29.75mm
Working Humidity: 10~90%
Working Temperature: -10°C~ +45°C
Storage Temperature: -20°C~ +70°C
Touch Screen Display
Display Mode: Normally black, transmissive
LCD Size: 10 inch diagonal
Aspect Ratio: 16:10
Resolution: 1920 x 1200
Luminance: 350nits (cd/m²)
Contrast: 900:1
Viewing Angle: ±80° horizontal, ±80° vertical
Touch Screen: Projected Capacitive
Video
Streaming Formats: H.263 & H.264
Audio
SIPv1(RFC2543),SIPv2(RFC3261)
Narrowband audio codec: G.711a, G.711u, G.729
Broadband audio codec: G.722
DTMF: In-band, out-of-band DTMF(RFC2833), SIPInfo
Echo Cancellation
Voice Activation Detection
Comfort Noise Generator
Automatic Gain Control
Voice Assistant
Voice pickup distance up to 5 meters
Voice recognition accuracy up to 95%
Privacy Protection with native voice data
Akuvox IT88A Application Scenario
Download documents from the following links:
Akuvox IT88S Datasheet_190917_V2.0
Please ask your product question below:
Related products
Akuvox E18C 7” Face Recognition Door Phone
Login, Register, or Call for PriceGuest Price
Login to see Member Pricing
Aristel Exit Button – Plastic
$11.95Original price was: $11.95.$11.80Current price is: $11.80.Guest Price
Login to see Member Pricing
Akuvox X915S In-wall Rain Hood
Login, Register, or Call for PriceGuest Price
Login to see Member Pricing
Akuvox EC33 Elevator Controller
Login, Register, or Call for PriceGuest Price
Login to see Member Pricing
Akuvox Surface Mount Door Phone with Facial Recognition
Login, Register, or Call for PriceGuest Price
Login to see Member Pricing
Akuvox E21 In-wall Installation Kit
Login, Register, or Call for PriceGuest Price
Login to see Member Pricing
Akuvox S567W SIP 10″ Touch Screen (Android 12). WiFi 6
Login, Register, or Call for PriceGuest Price
Login to see Member Pricing
Aristel Door Latch – Power ON to lock – Requires adaptor
$59.00Original price was: $59.00.$49.50Current price is: $49.50.Guest Price
Login to see Member Pricing
Akuvox E12W Surface Mount Video Intercom with one Button, Card Reader, and WiFi
Login, Register, or Call for PriceAvailable on back-order
View productGuest Price
Login to see Member Pricing
Aristel 12VDC 1.5Amp Strike Power Supply
$18.70Original price was: $18.70.$16.50Current price is: $16.50.Guest Price
Login to see Member Pricing